• Sign Up! To view all forums and unlock additional cool features

    Welcome to the #1 Toyota 86 Forum and Toyota 86 community dedicated to Toyota 86 owners and enthusiasts. Register for an account, it's free and it's easy, so don't hesitate to join the Toyota 86 Forum today!

Turn signal

Messages
2
Reactions
0
#1
I own a 2015 frs and the turn signals work fine. When I lock and unclock the car the work fine but when the car is on 'auto' for lights or I simply have it on drl the right turn signal (front bumper not side) won't light up but the left will. I've replaced the bulb. I'm wondering if this is a common problem is it a fuse is it the wiring.

Any knowledge on the matter or experience helps.

Sent from my Pixel 2 XL using Tapatalk
 
Messages
2
Reactions
0
#2
I own a 2015 frs and the turn signals work fine. When I lock and unclock the car the work fine but when the car is on 'auto' for lights or I simply have it on drl the right turn signal (front bumper not side) won't light up but the left will. I've replaced the bulb. I'm wondering if this is a common problem is it a fuse is it the wiring.

Any knowledge on the matter or experience helps.

Sent from my Pixel 2 XL using Tapatalk
Update I've been checking fuses and most are good to go. For what ever reason I wanted to check the "stoping lights" fuse but it's stuck in and I've pretty well stripped it. Is there a better tool I can get than plastic tweezers or needle knows pliers?

Even then I have little faith in this fuse being my front right drl turn signal problem. Again it works for the necessity of a turn signal but it doesn't when they are drl.


Sent from my Pixel 2 XL using Tapatalk
 
Top